Firestarter firewall GUI 1.0.3-5 bug in initscript on system boot up

Posted by on Apr 11, 2008 in Technology1 comment

Firestarter LogoI recently installed Firestarter (a Firewall GUI for Linux – sometimes I just cant be arsed using CLI to configure iptables etc!), but I’ve noticed that when my system boots, it throws up the following error:

invoke-rc.d: initscript firestarter, action "restart" failed
run-parts: /etc/network/if-up.d/50firestarter exited with return code 2

This is actually a bug with version 1.0.3-5, and the solution is pretty simple – to upgrade to version 1.0.3-6. However, I have Ubuntu 64 Bit installed, and unfortunately, 1.0.3-6 is not yet available in the repositories. Not worries – just a simple case of downloading the source tar ball, compiling, and installing.

First, I removed the currently installed version:

sudo apt-get remove firestarter

and downloaded the latest tar ball. Once this had downloaded to my desktop, I went through my usual routine of creating a new directory, moving the file, extracting… and so on:

cd ~/Desktop
mkdir firestarter
mv firestarter-1.0.3.tar.gz firestarter
cd firestarter
tar -zxvf firestarter-1.0.3.tar.gz
cd firestarter-1.0.3

Installation is pretty straightforward – although it’s always good to read the README and INSTALL files!

more INSTALL

So, configure, make, and install:

./configure --sysconfdir=/etc
make
sudo make install

However, the configure step threw out a few errors for me:

Package libgnome-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libgnome-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libgnome-2.0' found Package libgnomeui-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libgnomeui-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libgnomeui-2.0' found Package gnome-vfs-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gnome-vfs-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gnome-vfs-2.0' found Package libglade-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libglade-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libglade-2.0' found
configure: error: Library requirements (libgnome-2.0 >= 2.0.0
libgnomeui-2.0 >= 2.0.0
gtk+-2.0 >= 2.4.0
gnome-vfs-2.0 >= 2.6.0
libglade-2.0 >= 2.3.6)

which basically means that I didn’t have some of the necessary development libraries installed required to compile the binaries. No real problem, and easy enough to solve by, well, installed in the required packages:

sudo apt-get install libgnome-dev libgnomeui-dev libgnome-vfs-dev libglade2-dev

This process also had to download an additional 50 packages to meet the dependencies of the above four packages (and there were probably some sub dependencies there too…)

Anyway, the configure process ran smoothly after installing the required dev libraries, so I could then run

make
sudo make install

to compile and install the new binaries.

It’s possible to have Firestarter run as a system service, by copying the fedora.init file from the install directory to /etc/init.d and renaming the file to firestarter, then enabling the script:

sudo cp fedora.init /etc/init.d/firestarter
sudo chkconfig firestarter reset

However, since I had previously installed Firestarter, all the relevant scripts and symbolic links were already in place. All I had to do was make a minor change to the /etc/init.d/firestarter script:

cd /etc/init.d
cp firestarter firestarter.old
gksu gedit firestarter

and changed the line

[ -x /usr/sbin/firestarter ] || exit 0

to

[ -x /usr/local/bin/firestarter ] || exit 0

so that the script would point to the new installed binary. That’s it.

Tags: ,